Next-Gen Antivirus for macOS 10.14 (and higher)